View Issue Details
ID | Project | Category | View Status | Date Submitted | Last Update |
---|---|---|---|---|---|
233 | Composr | core | public | 2010-12-28 18:31 | 2012-08-18 14:15 |
Reporter | Chris Graham | Assigned To | Chris Graham | ||
Priority | normal | Severity | feature | ||
Status | resolved | Resolution | fixed | ||
Summary | 233: Rename query_value_null_ok to query_value_if_there | ||||
Description | Rename two confusingly named functions: query_value_null_ok -> query_value_if_there query_value_null_ok_full -> query_value_if_there_full | ||||
Additional Information | The current names refer to how NULL is returned if there is no result (instead of exiting with an error), but most programmers will initially think it refers to a data value of NULL being acceptable. | ||||
Tags | Risk: Core rearchitecting | ||||
Attach Tags | |||||
Time estimation (hours) | 1 | ||||
Sponsorship open | |||||
Date Modified | Username | Field | Change |
---|---|---|---|
2016-06-08 00:15 | Chris Graham | Tag Renamed | Core rearchitecting => Risk: Core rearchitecting |